#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = " ?\(\w+\)"
Local $sString = "x (LOC)" & @CRLF & _
"ds ds (32C)" & @CRLF & _
"d'ds ds (LeC)" & @CRLF & _
"ds-d da(LOQ)" & @CRLF & _
"12345 (deC)" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)