import re
regex = re.compile(r" ?\(\w+\)")
test_str = ("x (LOC)\n"
"ds ds (32C)\n"
"d'ds ds (LeC)\n"
"ds-d da(LOQ)\n"
"12345 (deC)\n\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)