# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/"(field)"(\s*:\s*{)/"$1_obj"$2/gm;t' <<< "\"field\": {}
\"field\" : \"\"
\"field\":1"