using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""(field)""(\s*:\s*{)";
string substitution = @"""$1_obj""$2";
string input = @"""field"": {}
""field"" : ""
""field"":1";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}