use strict;
my $str = '"field": {}
"field" : ""
"field":1';
my $regex = qr/"(field)"(\s*:\s*{)/mp;
my $subst = '"$1_obj"$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";