import Foundation
let pattern = #""(field)"(\s*:\s*{)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
"field": {}
"field" : ""
"field":1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""$1_obj"$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)