# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/ ([^ :]*:)/ADDED STRING:$1/g;t' <<< "DefVariable 変数名:配列「n]
DefVariable 変数名:string
DefVariable 変数名:int
DefVariable 変数名:decimal
DefVariable 変数名:日付
DefVariable 変数名:時間"