import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " ([^ :]*:)";
final String string = "DefVariable 変数名:配列「n]\n"
+ "DefVariable 変数名:string\n"
+ "DefVariable 変数名:int\n"
+ "DefVariable 変数名:decimal\n"
+ "DefVariable 変数名:日付\n"
+ "DefVariable 変数名:時間";
final String subst = "ADDED STRING:$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}