# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r" ([^ :]*:)"
test_str = ("DefVariable 変数名:配列「n]\n"
"DefVariable 変数名:string\n"
"DefVariable 変数名:int\n"
"DefVariable 変数名:decimal\n"
"DefVariable 変数名:日付\n"
"DefVariable 変数名:時間")
subst = "ADDED STRING:$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.