import Foundation
let pattern = #" ([^ :]*:)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
DefVariable 変数名:配列「n]
DefVariable 変数名:string
DefVariable 変数名:int
DefVariable 変数名:decimal
DefVariable 変数名:日付
DefVariable 変数名:時間
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"ADDED STRING:$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)