const regex = / ([^ :]*:)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(' ([^ :]*:)', 'g')
const str = `DefVariable 変数名:配列「n]
DefVariable 変数名:string
DefVariable 変数名:int
DefVariable 変数名:decimal
DefVariable 変数名:日付
DefVariable 変数名:時間`;
const subst = `ADDED STRING:$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);