#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = " ([^ :]*:)"
Local $sString = "DefVariable 変数名:配列「n]" & @CRLF & _
"DefVariable 変数名:string" & @CRLF & _
"DefVariable 変数名:int" & @CRLF & _
"DefVariable 変数名:decimal" & @CRLF & _
"DefVariable 変数名:日付" & @CRLF & _
"DefVariable 変数名:時間"
Local $sSubst = "ADDED STRING:$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)