using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)<P .*?#0007'>\s*(.*?)\s*<\/SPAN.*?<\/P>";
string input = @"Some random stuff not part of the matched substring...<P class=MsoNormal
style=""MARGIN-BOTTOM: 0pt; LINE-HEIGHT: normal; TEXT-AUTOSPACE: ; mso-pagination: none; mso-layout-grid-align: none""><B><SPAN
lang=de
style='FONT-SIZE: 33pt; FONT-FAMILY: ""TimesNewRoman,Bold"",""serif""; mso-bidi-font-family: ""TimesNewRoman,Bold""; mso-ansi-language: #0007'>Teil
II<o:p></o:p></SPAN></B></P>and even more blub";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}