// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?s)<P .*?#0007'>\s*(.*?)\s*<\/SPAN.*?<\/P>").unwrap();
let string = "Some random stuff not part of the matched substring...<P class=MsoNormal
style=\"MARGIN-BOTTOM: 0pt; LINE-HEIGHT: normal; TEXT-AUTOSPACE: ; mso-pagination: none; mso-layout-grid-align: none\"><B><SPAN
lang=de
style='FONT-SIZE: 33pt; FONT-FAMILY: \"TimesNewRoman,Bold\",\"serif\"; mso-bidi-font-family: \"TimesNewRoman,Bold\"; mso-ansi-language: #0007'>Teil
II<o:p></o:p></SPAN></B></P>and even more blub";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}