import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)<P .*?#0007'>\\s*(.*?)\\s*<\\/SPAN.*?<\\/P>";
final String string = "Some random stuff not part of the matched substring...<P class=MsoNormal\n"
+ "style=\"MARGIN-BOTTOM: 0pt; LINE-HEIGHT: normal; TEXT-AUTOSPACE: ; mso-pagination: none; mso-layout-grid-align: none\"><B><SPAN\n"
+ "lang=de\n"
+ "style='FONT-SIZE: 33pt; FONT-FAMILY: \"TimesNewRoman,Bold\",\"serif\"; mso-bidi-font-family: \"TimesNewRoman,Bold\"; mso-ansi-language: #0007'>Teil\n"
+ "II<o:p></o:p></SPAN></B></P>and even more blub";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}