package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?s)<P .*?#0007'>\s*(.*?)\s*<\/SPAN.*?<\/P>`)
var str = `Some random stuff not part of the matched substring...<P class=MsoNormal
style="MARGIN-BOTTOM: 0pt; LINE-HEIGHT: normal; TEXT-AUTOSPACE: ; mso-pagination: none; mso-layout-grid-align: none"><B><SPAN
lang=de
style='FONT-SIZE: 33pt; FONT-FAMILY: "TimesNewRoman,Bold","serif"; mso-bidi-font-family: "TimesNewRoman,Bold"; mso-ansi-language: #0007'>Teil
II<o:p></o:p></SPAN></B></P>and even more blub`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}