re = /(?s)<P .*?#0007'>\s*(.*?)\s*<\/SPAN.*?<\/P>/m
str = 'Some random stuff not part of the matched substring...<P class=MsoNormal
style="MARGIN-BOTTOM: 0pt; LINE-HEIGHT: normal; TEXT-AUTOSPACE: ; mso-pagination: none; mso-layout-grid-align: none"><B><SPAN
lang=de
style=\'FONT-SIZE: 33pt; FONT-FAMILY: "TimesNewRoman,Bold","serif"; mso-bidi-font-family: "TimesNewRoman,Bold"; mso-ansi-language: #0007\'>Teil
II<o:p></o:p></SPAN></B></P>and even more blub'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end