const regex = /(?s)<P .*?#0007'>\s*(.*?)\s*<\/SPAN.*?<\/P>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)<P .*?#0007\'>\\s*(.*?)\\s*<\\\/SPAN.*?<\\\/P>', 'gm')
const str = `Some random stuff not part of the matched substring...<P class=MsoNormal
style="MARGIN-BOTTOM: 0pt; LINE-HEIGHT: normal; TEXT-AUTOSPACE: ; mso-pagination: none; mso-layout-grid-align: none"><B><SPAN
lang=de
style='FONT-SIZE: 33pt; FONT-FAMILY: "TimesNewRoman,Bold","serif"; mso-bidi-font-family: "TimesNewRoman,Bold"; mso-ansi-language: #0007'>Teil
II<o:p></o:p></SPAN></B></P>and even more blub`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}