#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^_]+_(.*)_[^_]+$"
Local $sString = "cito001_LULUXCACN_PZ46_DI_SA_DRITTLAND_20210422074609.csv" & @CRLF & _
"cito001_GBCVTBACN_DRITTLAND_033_Di_Fr_20210422051506.csv" & @CRLF & _
"adwfwm_NLHAGIACE_Export_028_DI_SA_20210422074803.csv"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")