package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^_]+_(.*)_[^_]+$`)
var str = `cito001_LULUXCACN_PZ46_DI_SA_DRITTLAND_20210422074609.csv
cito001_GBCVTBACN_DRITTLAND_033_Di_Fr_20210422051506.csv
adwfwm_NLHAGIACE_Export_028_DI_SA_20210422074803.csv`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}