const regex = /^[^_]+_(.*)_[^_]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^_]+_(.*)_[^_]+$', 'gm')
const str = `cito001_LULUXCACN_PZ46_DI_SA_DRITTLAND_20210422074609.csv
cito001_GBCVTBACN_DRITTLAND_033_Di_Fr_20210422051506.csv
adwfwm_NLHAGIACE_Export_028_DI_SA_20210422074803.csv`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}