import Foundation
let pattern = #"^[^_]+_(.*)_[^_]+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
cito001_LULUXCACN_PZ46_DI_SA_DRITTLAND_20210422074609.csv
cito001_GBCVTBACN_DRITTLAND_033_Di_Fr_20210422051506.csv
adwfwm_NLHAGIACE_Export_028_DI_SA_20210422074803.csv
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)