$re = '/^[^_]+_(.*)_[^_]+$/m';
$str = 'cito001_LULUXCACN_PZ46_DI_SA_DRITTLAND_20210422074609.csv
cito001_GBCVTBACN_DRITTLAND_033_Di_Fr_20210422051506.csv
adwfwm_NLHAGIACE_Export_028_DI_SA_20210422074803.csv';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);