import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^_]+_(.*)_[^_]+$";
final String string = "cito001_LULUXCACN_PZ46_DI_SA_DRITTLAND_20210422074609.csv\n"
+ "cito001_GBCVTBACN_DRITTLAND_033_Di_Fr_20210422051506.csv\n"
+ "adwfwm_NLHAGIACE_Export_028_DI_SA_20210422074803.csv";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}