# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\[[^\[\]]+\])\s+(\([^)]+\))/$1$2/g;t' <<< "Oprava markdown odkazu z Redmine s jednou nebo více mezerami mezi [] a ()
[text] (odkaz)
[text se spoustou češtiny] (https://www.odkazdohadichprdeli.com/tady-najdes_tu-blbost)"