// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\[[^\[\]]+\])\s+(\([^)]+\))").unwrap();
let string = "Oprava markdown odkazu z Redmine s jednou nebo více mezerami mezi [] a ()
[text] (odkaz)
[text se spoustou češtiny] (https://www.odkazdohadichprdeli.com/tady-najdes_tu-blbost)";
let substitution = "$1$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}