package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\[[^\[\]]+\])\s+(\([^)]+\))`)
var str = `Oprava markdown odkazu z Redmine s jednou nebo více mezerami mezi [] a ()
[text] (odkaz)
[text se spoustou češtiny] (https://www.odkazdohadichprdeli.com/tady-najdes_tu-blbost)`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}