import Foundation
let pattern = #"(\[[^\[\]]+\])\s+(\([^)]+\))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Oprava markdown odkazu z Redmine s jednou nebo více mezerami mezi [] a ()
[text] (odkaz)
[text se spoustou češtiny] (https://www.odkazdohadichprdeli.com/tady-najdes_tu-blbost)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)