re = /(\[[^\[\]]+\])\s+(\([^)]+\))/
str = 'Oprava markdown odkazu z Redmine s jednou nebo více mezerami mezi [] a ()
[text] (odkaz)
[text se spoustou češtiny] (https://www.odkazdohadichprdeli.com/tady-najdes_tu-blbost)'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result