$re = '/((?:(?:(?:[0-9a-fA-F]){1,4}):){1,4}:/[^\s:]\d{0,2})/m';
$str = '2001:db8::/32
fe80::/10
2001:db8:101::/56
2001:db8:3c4d:15::/64 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);