import re
regex = re.compile(r"((?:(?:(?:[0-9a-fA-F]){1,4}):){1,4}:/[^\s:]\d{0,2})", flags=re.MULTILINE)
test_str = ("2001:db8::/32\n"
"fe80::/10\n"
"2001:db8:101::/56\n"
"2001:db8:3c4d:15::/64 ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")