re = /((?:(?:(?:[0-9a-fA-F]){1,4}):){1,4}:\/[^\s:]\d{0,2})/m
str = '2001:db8::/32
fe80::/10
2001:db8:101::/56
2001:db8:3c4d:15::/64 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end