package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?:listget|name|number)\(([^\)]+)\)`)
var str = `name(abc1)
number(param9)
listget(12jtxgh)
(name(foo) & number(bar)) - listget(baz)
def number(param9)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}