re = /(?:listget|name|number)\(([^\)]+)\)/i
str = 'name(abc1)
number(param9)
listget(12jtxgh)
(name(foo) & number(bar)) - listget(baz)
def number(param9)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end