# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?<negative>\-?)(?<preceding>0?)(?<main>[0-9]+\.??[0-9]*?)(?<trailing>\.?0*)$/$1$3/mg;t' <<< "00.00
00.010
0.
11.010
11
123.123
-239.010
010.0010
-001.10"