$re = '/^(?<negative>\-?)(?<preceding>0?)(?<main>[0-9]+\.??[0-9]*?)(?<trailing>\.?0*)$/m';
$str = '00.00
00.010
0.
11.010
11
123.123
-239.010
010.0010
-001.10';
$subst = "$1$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;