use strict;
my $str = '00.00
00.010
0.
11.010
11
123.123
-239.010
010.0010
-001.10';
my $regex = qr/^(?<negative>\-?)(?<preceding>0?)(?<main>[0-9]+\.??[0-9]*?)(?<trailing>\.?0*)$/mp;
my $subst = '$1$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";