import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<negative>\\-?)(?<preceding>0?)(?<main>[0-9]+\\.??[0-9]*?)(?<trailing>\\.?0*)$";
final String string = "00.00\n"
+ "00.010\n"
+ "0.\n"
+ "11.010\n"
+ "11\n"
+ "123.123\n"
+ "-239.010\n"
+ "010.0010\n"
+ "-001.10";
final String subst = "$1$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}