#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:sandwich|toastie)(?:(?!\w\. ).){0,100}(ham|cheese|pickle)"
Local $sString = "Andy sat down to enjoy his sandwich which, unusally for him, was filled with delicious ham" & @CRLF & _
"Victorians enjoyed a good sandwich after work. They also enjoyed cheese rolling."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")