$re = '/(?:sandwich|toastie)(?:(?!\w\. ).){0,100}(ham|cheese|pickle)/m';
$str = 'Andy sat down to enjoy his sandwich which, unusally for him, was filled with delicious ham
Victorians enjoyed a good sandwich after work. They also enjoyed cheese rolling.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);