#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^\d{0,2}(?:\.\d{1,2})?$"
Local $sString = "12.23" & @CRLF & _
"2112.23" & @CRLF & _
"21.2" & @CRLF & _
"1.23" & @CRLF & _
"122.1" & @CRLF & _
"1.3232" & @CRLF & _
"12.323232"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")