package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\d{0,2}(?:\.\d{1,2})?$`)
var str = `12.23
2112.23
21.2
1.23
122.1
1.3232
12.323232`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}