import Foundation
let pattern = #"^\d{0,2}(?:\.\d{1,2})?$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
12.23
2112.23
21.2
1.23
122.1
1.3232
12.323232
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}