$re = '/^\d{0,2}(?:\.\d{1,2})?$/';
$str = '12.23
2112.23
21.2
1.23
122.1
1.3232
12.323232';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);