const regex = /^\d{0,2}(?:\.\d{1,2})?$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{0,2}(?:\\.\\d{1,2})?$', '')
const str = `12.23
2112.23
21.2
1.23
122.1
1.3232
12.323232`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}