using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d{0,2}(?:\.\d{1,2})?$";
string input = @"12.23
2112.23
21.2
1.23
122.1
1.3232
12.323232";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}