using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:[\t ]*(?:R|RE|F|FW|FWD):[\t ]*)*)(.*)";
string input = @"RE: RE:Fw: RE:FW: FWD: re: This is a message from a long thread re: asdf
Refund issued: Combination Padlock Lock Gym, School Locker, Sheds, Toolboxes Various Colours
Re: abc123 sent a message about Galvanised U Nails Netting Fencing Staples Chicken Wire Mesh Fences #123123123123
Request #0123456789: Buyer received a refund
Re: johndoe has sent a question about item #456456456456, ending on 03-Mar-19 05:48:20 GMT - Combination Padlock Lock Gym, School Locker, Sheds, Toolboxes Various Colours";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}