re = /((?:[\t ]*(?:R|RE|F|FW|FWD):[\t ]*)*)(.*)/mi
str = 'RE: RE:Fw: RE:FW: FWD: re: This is a message from a long thread re: asdf
Refund issued: Combination Padlock Lock Gym, School Locker, Sheds, Toolboxes Various Colours
Re: abc123 sent a message about Galvanised U Nails Netting Fencing Staples Chicken Wire Mesh Fences #123123123123
Request #0123456789: Buyer received a refund
Re: johndoe has sent a question about item #456456456456, ending on 03-Mar-19 05:48:20 GMT - Combination Padlock Lock Gym, School Locker, Sheds, Toolboxes Various Colours'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end