import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:[\\t ]*(?:R|RE|F|FW|FWD):[\\t ]*)*)(.*)";
final String string = "RE: RE:Fw: RE:FW: FWD: re: This is a message from a long thread re: asdf \n"
+ " Refund issued: Combination Padlock Lock Gym, School Locker, Sheds, Toolboxes Various Colours\n"
+ "Re: abc123 sent a message about Galvanised U Nails Netting Fencing Staples Chicken Wire Mesh Fences #123123123123\n"
+ "Request #0123456789: Buyer received a refund\n"
+ "Re: johndoe has sent a question about item #456456456456, ending on 03-Mar-19 05:48:20 GMT - Combination Padlock Lock Gym, School Locker, Sheds, Toolboxes Various Colours";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}