import Foundation
let pattern = #"((?:[\t ]*(?:R|RE|F|FW|FWD):[\t ]*)*)(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = ##"""
RE: RE:Fw: RE:FW: FWD: re: This is a message from a long thread re: asdf
Refund issued: Combination Padlock Lock Gym, School Locker, Sheds, Toolboxes Various Colours
Re: abc123 sent a message about Galvanised U Nails Netting Fencing Staples Chicken Wire Mesh Fences #123123123123
Request #0123456789: Buyer received a refund
Re: johndoe has sent a question about item #456456456456, ending on 03-Mar-19 05:48:20 GMT - Combination Padlock Lock Gym, School Locker, Sheds, Toolboxes Various Colours
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)